Slow image generation for new uploads

Incident Report for Zenfolio

Resolved

The system continues to perform as expected. This issue is resolved.
Posted Mar 25, 2025 - 15:38 PDT

Monitoring

Our engineers have implemented a fix. We will continue to monitor uploads to ensure image loading remains stable.
Posted Mar 25, 2025 - 13:04 PDT

Investigating

Some Classic accounts are seeing slow image generation for recently uploaded images. Our engineers are currently implementing a fix. Thank you for your patience while we work on this matter.
Posted Mar 25, 2025 - 11:33 PDT
This incident affected: Zenfolio Classic (Upload).